Configurando servicios web JAX-WS a través de un proxy Apache 2.X

Había configurado servicios web tras un Proxy de Apache Web Server. Los servicios web estaban en un servidor de aplicaciones tomcat en el puerto 8080. El servidor Apache redireccionaba las peticiones a dicho servidor. El archivo WSDL lo recibía sin problemas. Sin embargo los clientes no podían obtener la descripción de los servicios ya que en la respuesta WSDL  el parámetro schemaLocation apuntaba al puerto 8080:

 

… schemaLocation=”http://servidor_apache:8080/web_services/servicio_web?xsd=1″ ..

Para solucionar esto es necesario agregar la directiva ProxyPreserveHost y ponerla en On. Así la respuesta del WSDL me regresó la dirección correcta:

… schemaLocation=”http://servidor_apache:80/web_services/servicio_web?xsd=1″ ..

Las directivas dentro del archivo http.conf quedaron así:

ProxyRequests off

ProxyPass /web_services/ http://servidor_de_servicios_web:8080/web_services

ProxyPassReverse /web_services/ http://servidor_de_servicios_web:8080/web_services

ProxyPreserveHost On

Espero que les sirva.

 

Cámara Web Lynx View HD ATW-1200 de Acteck en Ubuntu 12.04

Cambié mi cámara web Logitech por que de pronto me ocasionaba problemas con el audio. Había ocasiones que al encender la computadora no había sonido y el control de volumen simplemente no estaba habilitado, era necesario reiniciar la máquina para que volviera habilitar el sonido.

Probé la cámara web  ATW-1200 de Acteck para ver si era reconocida por Ubuntu 12.04 y, efectivamente, Ubuntu enseguida la reconoció como un dispositivo tipo cámara Venus USB2.0. La probé con el programa chesse y me mostró tanto video como audio. Todo parecía funcionar bien hasta que quise usar la cámara web con skype. Al configurar la cámara con skype no me mostraba video, sólo sonido. Lo mismo me pasó con google-talk desde chrome, sólo me reconocían el audio pero no el video.

A buscar en internet y de las distintas soluciones que encontré, me funcionó lo siguiente.

En mi caso, cree y edite el archivo /etc/modprobe.d/options.conf con el siguiente contenido:

options uvcvideo quirks=64

Grabé el archivo, reinicié el equipo y tanto el Skype como Google-talk reconocieron la cámara web sin problemas.

Al parecer existe un problema con la velocidad de trasmisión de esta cámara ya que utiliza el USB 2.0 y este parámetro lo corrige. No estoy muy seguro de esto pero es cuestión de seguir investigando.

¡Saludos!

 

Insertar datos en una tabla extrayéndolos de otras tablas con Transact-SQL

Necesitábamos insertar datos en una tabla extrayéndolos de otras tablas. Todas las tablas con la misma estructura. Para evitar escribir muchas veces la misma instrucción con las diferentes tablas creamos el siguiente script  Transact-SQL en Sql Server 2000:

USE base_de_datos

DECLARE cursor_de_tablas CURSOR
FOR
  SELECT TABLE_NAME
  FROM INFORMATION_SCHEMA.TABLES WHERE TABLE_NAME LIKE ‘tablas%’

OPEN cursor_de_tablas

DECLARE @nombre_tabla sysname

FETCH NEXT FROM cursor_de_tablas INTO @nombre_tabla

WHILE (@@FETCH_STATUS <> -1)
BEGIN
  IF (@@FETCH_STATUS <> -2)
  BEGIN
    SELECT @nombre_tabla = RTRIM(@nombre_tabla)
    EXEC (‘INSERT INTO tabla_destino SELECT * FROM ‘ + @nombre_tabla )
  END
  FETCH NEXT FROM cursor_de_tablas INTO @nombre_tabla
END
CLOSE cursor_de_tablas
DEALLOCATE cursor_de_tablas

Con este script se insertarán los datos de todas las tablas que empiezan con el nombre tablas en la base de datos llamada base_de_datos a la tabla tabla_destino en la misma base de datos.

Espero y les sirva.

Problemas para ingresar (login) a Ubuntu 12.04 después de actualizar

Después de la actualización de paquetes de Ubuntu 12.04 del día 5 de Febrero del 2013 y reinicio del equipo, al ingresar al equipo con el usuario de siempre, entraba, mostraba el escritorio y un mensaje de Cairo-Dock donde me pedía confirmar si quería utilizar OpenGL e inmediatamente el escritorio se cerraba y me presentaba nuevamente la pantalla de ingreso (login). Al intentar ingresar nuevamente, ya no entraba al escritorio y solo me volvía a mostrar nuevamente la pantalla de ingreso.

Si entraba como usuario invitado u otro usuario no había problema, ingresaba normalmente. Al revisar los errores de X Windows en el archivo xsession-errors.log las primeras lineas me mandaban un X error. La causa: no estaba funcionando el OpenGL.

El problema eran los controladores (drivers) propietarios de la tarjeta NVidia que era necesario re-compilar. al parecer fueron afectado por la actualización de paquetes.

Para solucionarlo me cambie a la terminal no windows con las teclas

Ctl-Alt-F2

y paré el servicio de X windows, en mi caso, con

sudo service lightdm stop

y ejecuté la actualización de los drivers con el comando

nvidia-installer –update

seguí las instrucciones, reinicie el sistema y listo.

Mostrar cuánta memoria RAM tiene un servidor solaris 10

Me topé con la necesidad de saber cuánta memoria RAM tenía un servidor con sistema operativo Solaris versión 10. Para poder obtener la cantidad de memoria desde la linea de comando se ejecuta el siguiente comando:

/usr/sbin/prtconf | grep Memory

En mi caso me mostró una respuesta como esta:

Memory size: 4096 Megabytes

Lo que me indica que la memoria total del servidor es de 4 Gigabytes.

Espero les sirva.