Invitación al curso en línea de Postgis 2, edición 2018-2019.

Abierta la invitación para el curso en línea de Postgis 2 en su edición 2018-2019. Impartido por la Universidad Politécnica de Valencia, España.

Postgis es un complemento de  Postgresql para convertir a ésta en una Base de Datos Espacial.

Más información y costo, en el siguiente link:

http://cartosig.upv.es/curso_postgis/

¡Los esperamos!

Herramientas de SAGA no se muestran en QGIS 2.18 en Ubuntu 16.04

Después de instalar la versión de 2.18 de QGIS y de haber instalado la versión 2.2.3 de SAGA en mi PC con Ubuntu 16.04, las herramientas de SAGA no me aparecían en la caja de herramientas de QGIS.

Buscando en internet encontré la solución en el sitio de gis.stackexchange.com.

Cerré QGIS y edité el archivo:  /usr/share/qgis/python/plugins/processing/algs/saga/SagaAlgorithmProvider.py
Cambiando la línea 76:
if not version.startswith(‘2.3.’):
por:
if not version.startswith(‘2.2.‘):

Guardé cambios, ejecuté nuevamente QGIS y las herramientas de SAGA aparecieron. Al parecer las nuevas versiones de QGIS 2.18 busca la versión 2.3.x de SAGA, y es por eso que no inicializaba las herramientas.

¡Hasta la próxima!

shp2pgsql: el programa no puede iniciarse porque falta libiconv~2.dll

Hola a todos.

¿Te sucede que al ejecutar la utilería de postgis shp2pgsql, en la consola ms-dos de windows, te manda el siguiente mensaje de error?

Esto sucede con algunas versiones superiores a postgresql/postgis 9.2; debido a que las librerías .dll que necesita este programita ya no están más en el directorio bin de la carpeta de instalación de postgresql.

Ahora se encuentran esos .dll dentro de directorio bin/postgisgui dentro de la misma carpeta de instalación de postgresql.

Para solucionar el error, basta con agregar a tu variable de ambiente PATH este directorio, abrir una nueva ventana de consola de ms-dos y volver a ejecutar desde ahí el comando.

¡A convertir shapefiles a postgresql/postgis!