PgAdmin III, pg_dump error por incompatibilidad de versiones

Bueno, puede ocurrir que cuando tenemos o tuvimos instaladas varias versiones de la base de datos PostgreSQL ya sea en windows o linux nuestro cliente pgAdmin III apunte a los binarios de las herramientas de PostgreSQL más antiguos que los que la versión de la base de datos a la que nos estamos conectando. Si intentamos hacer un backup de la información a través de nuestro pgAdmin podrá arrojarnos el siguiente mensaje o algo parecido y abortar el respaldo:

….
pg_dump: server version: 9.3.1; pg_dump version: 9.1.0
….

Esto lo que indica, como lo expresé antes, es que estamos conectándonos a una base de datos más nueva (versión 9.3.1 en el ejemplo) y los binarios en nuestro cliente pgAdmin están apuntando a los binarios más antiguos (9.1.0 en este caso). En el caso contrario, cliente apuntando a binarios más nuevos, no ocasiona ningún problema.

Para solucionar el problema lo que se tiene que hacer es cambiar la ruta de los binarios de PostgreSQL en pgAdmin de la siguiente forma:

Seleccione el menú File > Options.., lo que abrirá el diálogo de Opciones de pgAdmin. Una vez ahí seleccione Browser>Binary paths, ingrese la ruta de los binarios más actuales de PostgreSQL en la opción PG bin path ya sea escribiéndola o usando el botón Browse que se encuentra a la derecha y oprima el botón OK.

 

Options pgAdmin

Refresque el pgAdmin y el backup o respaldo ya debe funcionar sin problemas.

¡Saludos!

Deja un comentario