WordPress libera su nueva versión 3.9

La versión 3.9 de WordPress, llamada “Smith” en honor al organista de Jazz Jimmy Smith, está disponible para descarga o actualización en tu escritorio de WordPress. Esta distribución trae una serie de mejoras que esperamos te encanten.

Visita el blog del sitio WordPress en español para más información de las novedades y mejoras.

 

Version 3.7 de WordPress ya está disponible.

Ya está disponible para descarga o instalación desde el Escritorio la versión 3.7 de WordPress, cuyas principales novedades son las siguientes:

  • Actualizaciones automáticas en segundo plano: nunca más tendrás que actualizar versiones de seguridad o mantenimiento pues WordPress se actualizará en segundo plano y sin necesidad de intervención del usuario. Esto solo afecta a versiones menores (p.ej: de la versión 3.7 a la 3.7.1).
  • Actualización automática de traducciones de WordPress: las traducciones a tu idioma, si varían, también se actualizarán automáticamente.
  • Nuevo sistema de comprobación de contraseñas, que detecta fallos comunes en la generación de claves por parte del usuario.
  • Mejoras en el buscador interno, que ahora mostrará los resultados por relevancia y jerarquía.
  • Mejora en las queries por fecha de WP_Query

Nueva versión 3.6.1 de WordPress

Acaba de ser liberada la versión 3.6.1 de WordPress, una actualización que resuelve 13 errores y algunos fallos de seguridad:

  • Bloquea “deserializaciones” de PHP  no seguras que podrían, en algunas instalaciones y configuraciones, conducir a ejecución de código remoto. Reportado por Tom Van Goethem.
  • Previene que un usuario con rol de Autor, utilizando una llamda muy elaborada, pueda crear una entrada “escrita por” otro usuario. Reportado por Anakorn Kyavatanakij.
  • Arregla validaciones de entrada insuficiente que podría conllevar una redirección a otras webs. Reportado por Dave Cummo, de Northrup Grumman subcontratados por  U.S. Centers for Disease Control and Prevention.

También se han ajustado algunas restricciones de la subida de archivos para limitar el riesgo de “cross-site scripting”.

Al ser una versión de seguridad, se recomienda encarecidamente actualizar las instalaciones. Basta con ir a Escritorio –> Actualizaciones.

(Esta entrada es una adaptación de la oficial en inglés).

Puedes encontrar más información sobre actualizaciones en el Codex.